• Update error

    From pinnerite@pinnerite@gmail.com to alt.os.linux.ubuntu on Sun Jan 24 21:06:38 2021
    From Newsgroup: alt.os.linux.ubuntu

    Is there a fix for this?

    'http://download.virtualbox.org/virtualbox/debian 20.04 Release' does not have a Release file.

    TIA


    --
    Mint 20.04, kernel 5.4.0-42-generic, Cinnamon 4.6.7
    running on an AMD Phenom II X4 Black edition processor with 8GB of DRAM.
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From azigni@azigni@yahoo.com to alt.os.linux.ubuntu on Mon Jan 25 05:35:39 2021
    From Newsgroup: alt.os.linux.ubuntu

    On Sun, 24 Jan 2021 21:06:38 +0000, pinnerite wrote:

    TIA

    Fix for what exactly?
    --- Synchronet 3.18a-Linux NewsLink 1.113
  • From Paul@nospam@needed.invalid to alt.os.linux.ubuntu on Mon Jan 25 02:41:03 2021
    From Newsgroup: alt.os.linux.ubuntu

    azigni wrote:
    On Sun, 24 Jan 2021 21:06:38 +0000, pinnerite wrote:

    TIA

    Fix for what exactly?

    There are two ways to install VirtualBox.

    You can go to the Package Manager and do it from there.

    Or you can go to the VirtualBox.org website and download it from there.
    There are packages per distro, to better fit local conditions
    in the distro.

    Both should be equally good methods.

    I have seen the "does not have a Release file" error before, and
    just used the other alternate method as a replacement. It's possible
    I was in Kali at the time, like someone in the threads here mentions.
    I recently installed a Kali for some fun, and may have tried
    to add VirtualBox to the setup.

    This thread does a good job of "hinting" at where the
    problem comes from.

    https://unix.stackexchange.com/questions/501449/apt-get-update-error-in-kali-linux-that-i-dont-understand

    Now, look at how VirtualBox downloads are set up.

    http://download.virtualbox.org/virtualbox/6.1.18/

    virtualbox-6.1_6.1.18-142142~Ubuntu~bionic_amd64.deb 12-Jan-2021 17:32 85M
    virtualbox-6.1_6.1.18-142142~Ubuntu~eoan_amd64.deb 12-Jan-2021 17:32 86M
    virtualbox-6.1_6.1.18-142142~Ubuntu~trusty_amd64.deb 12-Jan-2021 17:32 91M
    virtualbox-6.1_6.1.18-142142~Ubuntu~xenial_amd64.deb 12-Jan-2021 17:32 91M

    There's nothing for feisty fossil as an explicit separate item.

    https://www.virtualbox.org/wiki/Linux_Downloads

    "Ubuntu 19.10 / 20.04" Eoan and Fossil - can the Release field cover both ?

    So the problem is related to that somehow, or, a second
    possibility, is a Debian file is being installed instead
    of a Ubuntu file. Like trying to use a Debian 10 Buster
    version to cover Ubuntu 20.04.

    If you could find the download the tree uses, then issue the
    command manually, it's possible that might work. Or, maybe not :-)
    I like to keep things in-tree, if I can.

    Here is some quoted text from that web page. Maybe
    Ubuntu is doing this in their tree, on your behalf.
    Where "debian" would be replaced by "ubuntu",
    and "buster" would be replaced by "fossa".

    Debian-based Linux distributions

    Add the following line to your /etc/apt/sources.list.

    deb arch=amd64 https://download.virtualbox.org/virtualbox/debian buster contrib

    A person could check their sources.list and see what's
    currently in it. Because it's possible Canonical is loading
    VirtualBox directly from Oracle, instead of staging it
    on a canonical server, in a Canonical tree.

    That web page does kinda give you some hints and things to check.
    But I was in too much of a hurry to pay attention, when I ran
    into that error message.

    I don't like it, when bugs stack on top of one another,
    and I just steamroll some of them, to get on with things :-)

    Paul
    --- Synchronet 3.18a-Linux NewsLink 1.113